ID Plus Service Incident (SMS / Voice telephony)
Incident Report for RSA ID Plus
Resolved
After monitoring, SaaS Operations has determined that the incident affecting RSA ID Plus has been resolved.

We will post a root cause analysis as soon as it is available.
Posted Apr 05, 2024 - 20:24 UTC
Identified
We have detected an issue with SMS delivery delays affecting the ID Plus telephony services. Customers may be seeing a delay in SMS and Voice authentication.

RSA SaaS Operations is working with our telephony services providers on the issue and will post updates as they become available.
Posted Apr 05, 2024 - 17:19 UTC
This incident affected: RSA ID Plus Telephony Services (SMS, Voice).