RSA SecurID Access Service Incident (NA Region)
Incident Report for RSA ID Plus
Postmortem

An incident that occurred on February 26, 2021 caused degraded authentication services for customers hosted from NA2. This was caused by a scheduled database maintenance task that was introduced as part of the February release. The new maintenance tasks was written to prevent data buildup that has been related to past performance issues. This maintenance task introduced a condition that cause database performance degradation for some SecurID Access Pods, primely impacting North America pods NA2.

Mitigations

RSA is continuously taking steps to improve the RSA SecurID Access service and processes to help ensure such incidents do not occur in the future. This includes, but is not limited to:

·         Once the problematic database operation was identified, it was disabled from all production instances.
·         SecurID Engineering conducted a full review of this operation and has implemented an enhanced code review process for all changes at the DB level.

Posted Jun 15, 2021 - 14:38 UTC

Resolved
After monitoring the fix, RSA SaaS Operations has determined that the incident affecting RSA SecurID Access has been resolved.

RSA will post a root cause analysis as soon as it is available.
Posted Feb 26, 2021 - 03:50 UTC
Monitoring
RSA has detected an issue affecting RSA SecurID Access.
RSA SaaS Operations is investigating the issue and will post updates as they become available.
Posted Feb 26, 2021 - 03:35 UTC
Investigating
RSA has detected an issue affecting RSA SecurID Access.
RSA SaaS Operations is investigating the issue and will post updates as they become available.
Posted Feb 26, 2021 - 03:21 UTC
This incident affected: NA (na2.access Authentication Service).