RSA is performing maintenance on the RSA SecurID Access Cloud Authentication Service to upgrade all customers to the January 2021 release.
All RSA SecurID Access cloud services will remain online and available throughout the upgrade.
Posted Jan 26, 2021 - 16:00 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Jan 20, 2021 - 19:38 UTC
Scheduled
RSA will be performing maintenance on the RSA SecurID Access Cloud Authentication Service to upgrade all customers to our January 2021release. All RSA SecurID Access cloud services will remain online and available throughout the upgrade.