RSA ID Plus Telephony Services (US Region)

Incident Report for RSA ID Plus

Resolved

After monitoring the fix, SaaS Operations has determined that the incident affecting SMS delivery to the United States has been resolved.

We will post a root cause analysis as soon as it is available.
Posted Aug 29, 2025 - 00:12 UTC

Monitoring

Our SMS Partner has marked the issue as resolved at 21:00 UTC. We will continue to monitor for any remaining issues.
Posted Aug 28, 2025 - 21:22 UTC

Identified

We are currently experiencing service degradation affecting SMS delivery to the United States. Customers may notice delays or difficulties when sending messages to US-based recipients.

Our team is actively working with our SMS partners to resolve the issue as quickly as possible. Voice OTP is not impacted and remains available as an alternative authentication method.
Posted Aug 28, 2025 - 19:42 UTC
This incident affected: RSA ID Plus Telephony Services (SMS).